Mac Pro 1,1 And Mavericks

sysrep

Back in 2012 I made a numer of upgrades to my Mac Pro to try to extend its useful life.  The upgrades were a success and the posts I made such as upgrading the Xeon CPUs remain some of this blog’s most popular.  It therefore seems likely that I’m not alone in still running one of these venerable machines.

After what seems like an eternity waiting for the new Mac Pro to arrive, as superb as it is it doesn’t suit my needs.  After factoring in the costs of adding Thunderbolt equipped external storage it is also impossible to justify the cost.  From a performance perspective I’m still not suffering any great hardship with my Mac Pro 1,1.  However I have a number of other Macs and have become accustomed to running OS X Mavericks and would really like to be able to run it on the 1,1.

The last version of OS X officially supported for the Mac Pro 1,1 is 10.7.5 Lion.  Later versions require a 64bit EFI to boot.  My Pro is the very first of the Intel machines introduced and is crippled by a 32bit EFI although the Xeon CPUs are of course 64 bit.  A number of hacks have been in the wild for some time and allow you to get around this limitation.  The most common I’ve seen being running the Chameleon boot loader from a separate drive using legacy boot, Jabbawok created a guide.

gb

Useful Increase Under Mavericks

Recently it has become possible, thanks to the excellent work of Tiamo over on the Mac Rumours forum to install Mavericks on the 1,1 without the need for Legacy Boot and additional drives.  I actually took an alternative route to get Mavericks on to my 1,1 but still required Tiamo’s rewritten boot.efi.

Some months ago I managed to install a later, unsupported version of OS X onto both my iMac G4 and Cube.  This was achieved by launching the machines in Target Disk Mode (TDM), attaching them via Firewire to my Mac Mini G4 and running the installation from there.

I decided therefore to attempt the same trick with the Mac Pro.  I removed all other drives and inserted a new Crucial M500 SSD, booted the machine into TDM and attached it via Firewire to my Mavericks friendly 2010 iMac.   I ran the Mavericks installation via the iMac and after initialising the new SSD installed the OS.  When the installation had finished and before rebooting I used the iMac to overwrite the boot.efi in the following two locations on the new drive with Tiamo’s modified version.

usr/standalone/i386

system/library/coreservices

I find the easiest way to find these directories is to launch terminal and enter ‘open -a finder /volumes/volumename/usr/standalone/i386’ where ‘volumename’ is the name of the disk on which you’ve just installed Mavericks and ‘open -a finder /volumes/volumename/system/library/coreservices’.  This will launch Finder windows with the correct directories, you can then drag the boot.efi in to place.

_1060163

Velocity Solo PCI Card

Afterall you don’t want to accidentally overwrite the boot.efi on the machine you’re using to run the installation.  Upon reboot the Mac Pro dutifully launched OS X Mavericks, success!  After setting everything up I now have full iCloud and Internet Accounts integration with Twitter, Facebook and so on all working with the Notification Centre.  As yet I have not experienced any problems.  I do wonder whether any future updates from Apple may wreck things, time will tell.

One easy to resolve problem this process had left me with was that I had to remove a drive to accommodate the new SSD.  I wanted to keep my previous Lion installation intact so I could boot into it when required.  The drive I therefore removed contains my Windows 7 64 Bit installation which itself had involved a fair amount of jiggery pokery to get running and still gets used regularly.

sand

SSD Attached And Ready To Install

With all my drive bays full, I have a 4tb RAID occupying the last two slots, I decided to order a Velocity Solo PCI card from Apricorn.  This card will hold a single SSD and support booting from the drive.

Installation was very straightforward, simply attach the SSD and slot into a spare PCI bay and you’re good to go.  You also get an additional SATA connector on the card which may come in handy.

Everything is working very well at the moment, I even saw an improvement in my Geekbench score under Mavericks, an additional 400 points or so.  The machine definitely feels snappier under Mavericks so hopefully, barring hardware failures, another couple of years out of this extraordinary machine.

Update:- An interesting footnote, running Geekbench simultaneously under Mavericks and Windows 7 via Parallels yields multi-core results of 7555 and 3905 respectively.

Update (24/02/2014):- Updating to OS X 10.9.2 will overwrite your boot.efi files and prevent your installation from booting.  The new boot.efi file in the coreservices folder is locked and tricky to remove or overwrite.  To get around this simply reboot again in target disk mode and copy the boot.efi over from another machine.

Update (27/05/2014):- Have updated to 10.9.3 with no apparent problems.  It appears there is no need to restore the boot.efi after this update as it is not overwritten.

Update (15/07/2014):- Updated to 10.9.4 with no apparent problems.

Update (09/10/2014):- Updated to 10.9.5 with no apparent problems.  Please note however this was done via Software Update.  I have read that some people have encountered problems when downloading the combined update from Apple and applying it.  This may overwrite the boot.efi so be prepared to repeat target disk mode method of restoring Tiamo’s boot.efi where necessary.

Update (07/11/2014):- Updated to Yosemite – https://retrocosm.net/2014/11/07/mac-pro-11-yosemite-install/

109 thoughts on “Mac Pro 1,1 And Mavericks

  1. Nice work! I’ve just installed Mavericks on my MacPro 1,1 using the SFOTT boot patcher, and all seems to be fine apart from the fact that the system is reporting only 3GB of the 5GB RAM installed. Do you have any suggestions?

    Like

    1. Hi, nice writeup. I did something similar but with a faster solid state disk setup with this card from io-switch.com. Plug and play, no drivers needed, shows up as a drive, and is hecka fast being directly on the PCIe bus, without the SATA controller bottleneck (3Gbps or 6Gbps). I went with the 256GB card.

      Like

    2. I did a reset of the NVRAM last night and on next boot into Mavericks, my trusty workhorse reported 5GB of RAM. I’m not knowledgeable enough on the subject matter to know precisely if that was indeed the solution, but at least I’m pretty convinced I can now go and grab some more RAM and an SSD to give this machine a little more life.

      Thanks for the help 🙂

      Like

      1. Glad you got it sorted Tim, the SSD will really give your Pro a new lease of life and depending on what you’re doing I’d go for at least 4 Gig of RAM for each core.

        Like

  2. Is there anyway you can post the steps in detail. I dlike to put mabericks on my macpro1,1 . I’m just that not that smart. So if you could please I dlike simple steps to follow . Thank you .

    Like

    1. Thanks for replying ! Yes I did that before but it didn’t work! And I read your post about how you used another imac to do it ! It seemed easier I do have imac that has maverick on it ! So I wanted to try your way !

      Like

  3. Partition and format the drive on which you want Mavericks to your requirements, label the drive something that helps you easily identify it, ‘Mavericks’ would be good. Remove all the drives from the Mac Pro, except this newly partitioned drive. Get a Firewire cable and connect the Mac Pro and iMac. Restart the Mac Pro, while holding down the T key until you see a white screen with the Firewire logo.

    The drive in the Mac Pro should now show up on your iMac as an external drive. Run the Mavericks installer on the iMac and select the newly created drive ‘Mavericks’ to install onto. Let the installer complete.

    Provided you labelled your Mavericks drive in the Mac Pro, Mavericks then launch Terminal on the iMac and enter:-

    open -a finder /volumes/Mavericks/usr/standalone/i386

    A finder window should open. Drag Tiamo’s boot.efi from wherever you have it (on the desktop would be good) into the this new Finder window and overwrite the existing boot.efi

    In terminal again, enter:-

    open -a finder /volumes/Mavericks/system/library/coreservices

    Overwrite the boot.efi here as well as above with Tiamo’s.

    Reboot your Mac Pro. If you have a supported graphics adapter it should boot without problem.

    Hope this helps, worked for me. Be careful that you don’t overwrite anything on the iMac.

    Like

    1. Wonderful experience. From a MBP 17″ on and compatible to Mavericks, I followed your schedule just above. I would add that I changed out my wireless Logitech wave keyboard for a usb-wired board in order for the gutted 1-disk MPro to gain target mode. Oddly I did not see it ever display the target icon…but I proceeded anyway as its prepped disk and boot mounted on the MBP. I also restarted the compatible laptop after Mavericks installed to the target partitioned disk on the MPro before overwriting the Boot.efi in the two locations. It was important to make sure and go to System Prefs of the MBP to make sure the startup on the MBP was its original HD. After restarting the prepared MPro and verifying some of it, I shut it down and then re-installed the three Hdrives it had had. No problems of any significance developed in restarting and just the usual housekeeping that happens when you get a new unit. Thanks ever so much. Stellar.

      Like

      1. That’s good to hear. I would urge people to keep a secondary machine around with Tiamo’s boot.efi on it in the eventuality that any update to Mavericks overwrites the files on the Mac Pro. This way you can quickly replace them again.

        Like

      2. I found that out the hard way. The update to 10.9.2 replaced the boot.efi file and locked it. I have a second boot disk on my Pro and even though it booted, I still could not replace the file. I had to connect my MBP via firewire and boot the Pro in target mode to fix it. I have a feeling the update to 10.9.3 will do the same thing, when it comes out.

        Like

  4. Hi Retrocosm,

    I’ve installed mavericks on a second partition from another machine and replaced the boot.efi file in both places. The Mac Pro 1,1 verbose boots, but gets stuck in a boot loop and the OS itself won’t startup. Any suggestions?

    Like

  5. Thank you for this. I’m running Mavericks on my MacBook Pro, and wanted to run it on my Mac Pro 1,1 but didn’t want to mess around with Chameleon, after hearing about compatibility issues. Installed via FireWire via your instructions, and it works GREAT. The machine is flying along and EVERYTHING works perfectly. This weekend she is getting her dual core Xeons replaced with quad cores. This machine will easily have another two or three years of life.

    Like

    1. Processor upgrade has been completed. Before the upgrade, I upgraded the firmware and my Pro now reports that it is a 2,1 instead of a 1,1. Upgrade went without a hitch, and it is running great. I documented the upgrade on Facebook in the PowerMac & Mac Pro users forum.

      Like

    2. Well, I upgraded the processors in my Mac Pro last Saturday to two 5355 quad cores. Before doing that, I upgraded the firmware and my machine now reports that it is a 2,1 instead of a 1,1. Processors went in fine, and machine recognizes them and all eight cores. This brings my final configuration up to:

      2 5355 quad core Xeon processors @ 2.66 Ghz
      24 GB RAM
      ATI Radon HD 4870 GPU with 1 GB VRAM
      1.25 TB Fusion drive

      All was running well and I put it through it’s paces for the rest of the day with no problems. Then the next day (yesterday) I decided to install a Windows 7 VM under Parallels Desktop 9. I gave the VM the following configuration:

      4 cores
      8 GB RAM
      100 GB disk.

      Install went fine, and completed in about 30 minutes. Then I started loading the updates. I thought they would never end. It took at least 5 hours and countless reboots to get Win 7 up to date, but again, everything ran fine. I decided I wanted to run Windows Performance Index and see what Windows thought of the hardware I installed it on. It all started well and good, but towards the end of the tests, the fans in my Mac Pro switched to high gear, and I thought it was going to take off, it was so loud. I tried to cancel the WPI, but the Mac had frozen solid, and I ended up having to manually power off. I let it sit for a while, and when I powered it back on, it booted, but the fans were still running at full speed. I did some research and found that probable cause for the fans was the SMC needed to be reset. I reset it, and the fans are running normally again now, however I haven’t attempted to bring Windows back up for fear it will happen again. Any idea what went wrong or any suggestions? Any help is greatly appreciated.

      Like

      1. You could stress it out under Mavericks and see if you can replicate the problem. My PowerMac G5 had a very similar problem, it would work for a while and then it would kernel panic and there would be a thermal runaway with the fans cranked to full tilt and man are they noisy. I’m just wondering if your new CPUs are genuinely overheating, which would suggest a problem with the thermal connection between heatsinks and the processors or whether there’s another issue.

        Like

      2. Thank you for the reply! It is much appreciated. I made sure the heat sinks were clean, and we used Evercool Thermal paste (seller shipped it with the processors) when the new processors were installed.. I ran Geek Bench both before and after the upgrade. I saved the output, but there is no way to share them here. Anyway. after this problem occurred, I downloaded SMC Fan Control, but I left the defaults to the Apple defaults as of now. It reports that under minimal load, the processors are running at about 38 – 42 C, and when I run Geek Bench, the temp goes up to between 58 – 65 C. How else can I put a load on it to further test?

        Like

      3. Those temps don’t sound too bad to me, mine dropped consistently over a 2-3 month period as the thermal compound settled in. Just use the machine for what you need it for for a few weeks and see how it settles down.

        Like

  6. I found that out the hard way. The update to 10.9.2 replaced the boot.efi file and locked it. I have a second boot disk on my Pro and even though it booted, I still could not replace the file. I had to connect my MBP via firewire and boot the Pro in target mode to fix it. I have a feeling the update to 10.9.3 will do the same thing, when it comes out.

    On another note, I combined my 128 GB SSD and my 1 TB HDD into a Fusion drive. WOW. This thing is a speed demon now.

    Like

  7. Your instructions worked great. The only problem I’ve run into is that my video card, which is an ATI Radeon x1900 XT will not let me adjust screen resolutions, nor will it work in dual-display mode. Do you know a way to fix this without me having to shell out money for a new video card? Thanks!

    Like

  8. Ok. Being that I use my MacPro for video editing, and I also have a partition running Windows XP for gaming, which card(s) would you recommend? Thanks!

    Like

    1. I think the Mac edition ATI 5770 is a great card for the 1,1. However you need to take into account what ports you need on it. I have two Apple 24″ LED displays with mini-display port connectors so it’s perfect for me.

      However it is very expensive in relation to it’s PC counterparts. I think with Mavericks you have a bit more flexibility with the card you can use.

      Like

  9. Worked like a charm. The only problem I ran into is that now the ATI Radeon x1900 XT is showing only 8MB of ram instead of 512MB. Any ideas how I can get that sorted? I was researching kext’s and there seems to be no kext for the x1900 series, it’s starting from the 3000 upwards. Could that be the problem?

    Like

  10. Regarding your TDM method…
    I have a 2012 Macbook Pro and a Mac Pro 1,1 (with a 5770 video card and 6GB RAM), but I do not happen to own a Firewire 800 cable.
    And living here in the sticks, there is nowhere nearby that sells one, unfortunately (and I am impatient and hate waiting for mail-order items, ha).

    So here is my question/idea: Would it work the same way by simply doing the install from the MBP on a drive that’s in an external enclosure (which I DO already have), swapping the boot.efi files, and then moving the drive into the Mac Pro?

    Of course, if this isn’t an option, I guess I will just order a cable and be patient.

    Thanks in advance for your feedback.

    Like

  11. Yes it should do, run the Mavericks installer with the drive attached and see if it’s listed as an available drive for installation. What I don’t know is whether the installation will be geared towards your laptop and whether this will resolve itself when booted in the Mac Pro, but worth a try if you have a spare HDD.

    Like

  12. @Retroscosm: Do you happen to have any numbers (e.g. Black Magic Disk Speed Test) for your SSD upgrade?

    Would be interested to know what kind of test results you got using your SSD drive in the MacPro1,1’s PCIe1.0 slots. My understanding is that the 1.0 version of the PCIe bus in our MacPro1,1 and MacPro2,1 machines limits SSD transfer rates pretty severely – especially if you don’t have a 16-lane slot to install it in.

    My MacPro1,1 has had the quad-core CPU and 6870 graphics upgrades and is running 10.9.2 like a champ. Just trying to figure out whether I could best squeeze more performance out of a SATA- or PCIe1.0-based SSD storage upgrade.

    Like

    1. Hi Steve, frustratingly I can’t run the Blackmagic test on the SSD that I have installed via the Apricorn card as I have Windows 7 on it and it considers it a read only drive. However I have noticed that system report lists the negotiated link speed as 6 Gigabit, as opposed to 3 Gigabit for drives connected to the onboard SATA.

      Like

      1. I installed a 500GB Samsung 840 EVO (NOT the Pro, which would be a waste on the MacPro1,1’s 3Gb/s SATA bus) on an ICYDOCK 2.5/3.5″ adaptor. Running the BlackMagic tests at even small xfer sizes I am getting close to 250MB/s, about twice the transfer rate that my latest-gen WesternDigital HDD was achieving! So it’s been a nice bump in speed, noticeably snappier (especially in Aperture) if not an earthshaking upgrade.

        Like

      2. Steve, you can saturate the bus by creating a RAID with two drives in separate bays. Using regular drives I was able to achieve speeds for both write and read in excess of 300MB/s. An option if you really want to push it.

        Like

      3. At one time I had a 2-drive RAID0 array that was a big step up from the stock 5400RPM drive that came with my MacPro1,1, but it was surpassed in speed by the WesternDigital HDD that I’ve now replaced with the even faster SSD. Plus managing the RAID0 under Lion/MtLion on an EFI32 machine using Chameleon – my EFI solution at the time, now supplanted by the Tiamo boot.efi – was sketchy at best.

        Like

  13. Hi, I’ve got a Mac Pro 1.1, A1186, 2.66 GHz dual core Intel Xeon 5150, ATI X1900XT, 8GB RAM. Running on OS X 10.6. It’s has been a very reliable machine and partial due of cost of replacing it I am looking into upgrading it to 64bit if possible!?

    If I am understanding your what is written above, it would be possible, even updating the EFI using Chameleon boot loader.

    Apart from the obvious: New OS, SSD card, replacing the ATI X1900XT and following the instructions above.

    My question is, would this be sufficient or should I look at upgrading the CPU also (and any other parts?)

    If I upgrade more hardware can I avoid having to use the Chameleon boot loader? As a question of stability would really matter to me. I use the machine for video and motion graphics and sometimes it take hours to do a render. It would heart breaking for it to fail in these moments…

    Any help or suggestions would be greatly appreciated.

    Damien

    Like

    1. I’m running my 3Ghz Mac Pro 1,1 with normal hdd on Mavericks now. I added 3G of RAM and swapped the X1900XT for an 8800GT. A very safe upgrade let’s say. I don’t think you’ll need to upgrade those CPU’s of yours. Now the modified Mac Pro 1,1 EFI stays 32bit, not 64bit. And the OS has been 64bit since the beginning. But yes, you’ll need to execute the procedure and use the 32bit to 64bit modified EFI to run Mavericks that doesn’t support non-modified 32bits EFI’s. It took me 3x to do it right. And then I got stuck with the X1900XT that only recognised 8MB. But now I’ve sorted that and the Pro is running like a charm!

      Like

      1. Thanks Oedipus!

        If I understood correctly, I will need to “execute the procedure” to be able to run 64bit OS, app’s and plug-in’s!

        I guess I will start with the most basic upgrade and if all goes well I can consider doing additional ones. A bit extra power and speed wouldn’t go astray…

        Like

  14. bot01, indeed. But the 1,1 has always been running 64bits OS’s and apps. Only the EFI (Mac “BIOS”) was 32bits.

    This summarizes it all very well:
    “It supports a 64-bit OS and runs 64-bit applications, but it cannot boot the 64-bit kernel, hence, if will not run Mountain Lion, but it will run Lion. But Lion will be the end of the line for first generation Mac Pros.

    In order to boot the 64-bit kernel of OS X a computer must have a 64-bit EFI boot ROM. Your Mac Pro only has a 32-bit EFI boot ROM, hence, it cannot boot the 64-bit kernel.”
    (source: https://discussions.apple.com/message/18900313#18900313)

    Like

  15. I do not get it. Why can Apple provide the modified boot.efi as well so that we can use Mavericks on the old MacPros if there is no hardware limitation?

    Like

    1. Because if the “latest and greatest” OS was usable, out of the box, on 8-year old machines, there would be less of an incentive to buy the NEW ones, which is where they make the REAL $…

      Like

      1. But still, it is is only the very first generation of the Intel MacPro and if there is no hardware limitation or other problems, they could use that as a positive marketing as well as being machines built to last….

        Like

  16. Will a Macpro 1,1 2006 EFI32 running 10.7.5 be able to run Tiamo’s procedure to change the boot.efi to EFI 64-bit be possible without re-installing the OSX? Also, once I’m running a 64-bit EFI boot does that mean my old macpro will now support booting a Velocity X2 apricorn SSD on a PCI-e 1.0 slot? If I booted off a USB with OSX Mavericks installer and installed it to the SSD would this work? Of course I would have to upgrade to a 5770 graphics card from what I’ve heard but so far I haven’t seen any posts with this configuration yet.

    Like

  17. Successfully installed Mavericks on my old MP 1.1, now update 10.9.5 has arrived, I read this wipes out the boot.efi, I’m a complete novice any help would be welcomed in what to do about the update.

    Like

    1. I have the same MP, and the up date didn’t overwrite the boot.efi for me. You can always re-patch the boot.efi if you created a sfott flash drive.

      Like

      1. Has this caused any problems to your system? I want to update my 1,1 to Mavericks and asked someone to help me, in response I got a long answer that I will shorten up by saying. I was told it’ll slow the system down, create problems and it has no benefits doing this.

        Also, does it affect your Windows partition at all?

        Like

      2. I applied the 10.9.5 update and now my mavericks won’t boot up at all, I guess it wiped he boot.efi, do I have to run the sfott again ?

        Like

      3. No problems on my system, apart from when I updated to 10.9.3 (I think) as that updater overwrote my patched boot.efi. All I had to do was boot up into my SFOTT flash drive installer, run the terminal script to re-patch the boot.efi on my SSD drive, and all has run smoothly since.

        Mavericks will run very poorly if you haven’t upgraded the graphics card to a newer, compatible card other than the one that came with the original Mac.

        My windoze partition is on it’s own boot disk, so no, it isn’t affected at all.

        Like

    1. Had to boot into my Lion HD, no joy with the Mavericks HD, I re-installed from the sfott flash drive and update 10.9.5 still comes up, I replaced the boot.efi with Tiamo’s one and still no boot up, don’t know what I am doing wrong, I followed the instructions to the letter.

      Like

  18. Hi.
    Im very frustrated right now.I really can’t install mavericks on my MAC PRO 1.1 with 2.1 efi upgraded 3.0 ghz processors.

    I created SFoTT key on an external drive but it can’t boot.It gets stuck on Apple Logo with a very “BOLD” spinning wheel.I enabled verbose mode still i get only after some loadings with the prompter.

    I installed Mavericks on the internal drive of MAC PRO in disk mode using Macbook Pro.After that i copied the boot.efi from Tiamo to the locations described…The same Apple Logo and in verbose mode the same command prompt.

    I then booted in Lion and with the SFoTT script i patched the Mavericks partition ..The same.

    I dont understand what is going on.

    Two weeks ago i had a disk with Mavericks installed and it worked great with my Geforce 7300 (not accelerated) but i deleted the partition because it was useless for my 4890 Radeon.

    Now i got a 7850 Radeon and i want to install Mavericks again to enable the Card but I’m not able to.Last couple of days i think i installed and created a lot of thumb drives and partitions with no positive results.

    Please help me.

    Like

    1. Have you tried putting back the Geforce 7300 and getting Mavericks installed and running again? If you can get that running again what happens when you swap the card? If that doesnt work you may need to obtain a card that works out of the box.

      Like

      1. the 7300 was on slot 2 and the radeon on slot 1.
        I removed the HD 7850 from Pci 1 and installed 7300 ALONE in the first slot.Mavericks Booted fine.Success,

        After that i installed the Radeon again in the 1st slot and the 7300 in the second..BOOM.Mavericks lis booting ok.

        I don’t really know what was the problem.

        Thank you sir.

        Like

    2. “I enabled verbose mode still i get only after some loadings with the prompter.”

      I don’t understand what this means but if you can post the last messages that show up on the console during boot before it hangs then we might be able to pinpoint the problem.

      Like

      1. So in verbose mode i see a lot of text running on screen and and suddenly apple logo appears….and after that 2 lines again (verbose mode again ) but in very very short time (less than a second ) and then, i got the prompter an a black screen only.

        Like

    1. I have a ATI Radeon HD 5770 1024 MB Graphics card in my Mac Pro 1.1 and Mavericks works fine, just waiting to now install Yosemite when someone comes up with an install for that.

      Like

  19. Thank you very much. The advice here was critical in my successful update to 10.9.5 on my mac pro 1,1 (ati 5770 vid card, two xeon 5355s). Thanks again!

    Like

  20. Thanks for the above – have applied the simple steps it to a successful Yosemite install, only used the black screen boot.efis instead from the following site: (Piker Bootloader) -https://mega.co.nz/#!ypJkmR5S!UK9waH_8y3bSx3IXkEsmM1V1ZyfMGE1ha45l57MA_ak – loaded with no problems using firewire from my macbook pro. Computer is Mac Pro 1.1 with ATI Radeon HD4870

    Like

  21. I checked out the specs for your computer; mine are very similar.

    Model Name: Mac Pro
    Model Identifier: MacPro1,1
    Processor Name: Dual-Core Intel Xeon
    Processor Speed: 3 GHz
    Number Of Processors: 2
    Total Number Of Cores: 4
    L2 Cache (per processor): 4 MB
    Memory: 19 GB
    Bus Speed: 1.33 GHz
    OS 10.6.8

    Like you I have a 64bit processor, but a 32bit EFI. I recently installed an ATI Radeon HD 5770 card, but when I reboot the computer the display goes awry (I have to unplug and replug the display in order to reset it). Is this because of the 32bit EFI? Would this hack fix the issue, as well as allow me to upgrade to a more current OS?

    Like

    1. Hi, if your 5770 is Mac compatible is should work out of the box and shouldn’t be affected by the EFI. I’ve been running a Mac edition 5770 in my Pro for a couple of years now. How are you connecting your monitor(s)?

      Like

  22. Hi Retrocosm,

    I am trying to replace the ‘distribution’, platformsupport.plist and boot.efi files in the Mavericks installer but it won’t let me. Am I missing something?

    Thanks in advance

    Like

    1. Hi Joel, I have never bothered to amend those files. I simply installed via the target disk mode and then overwrote the boot.efi once installation was complete. Which method are you using?

      Like

      1. Hey Retrocosm. I used to have a 1,1 but have moved up to a 5,1 now. I’m thinking of installing PCIe SSDs myself. Tell me, do your drives show up if you option boot?

        Like

      2. Funnily enough I have literally this week taken delivery of a 5,1 and installed a new Apricorn Velocity 2 PCI SSD card from which I boot the OS. All works perfectly and yes they do show up in option boot, I have Windows 7 installed on a second card. With Yosemite booting from the SSD via PCI it is screamingly fast.

        Like

      1. I’ll give it a look see in a mo, (took the card out and in the middle of a few tasks but with no card installed PCI says 5.0GT/s also).

        Like

      2. If you are running an actual MacPro1,1 you have a slow PCIe 1.0 bus and the fastest transfer rate you will ever see is 2.5GT/s.

        The 2008 MacPro3,1 was the first to incorporate any PCIe 2.0 slots, which max out at 5GT/s. See: http://www.everymac.com/systems/apple/mac_pro/faq/mac-pro-how-to-install-pci-card-how-many-pci-slots.html

        Related note: the internal drive bays on MacPro1,1 through 2008 MacPro3,1 models include only a SATA II interface which tops out at 3Gb/s, limiting the utility of SSD upgrades. There are options available to convert those SATA II connections to 6Gb/s SATA III, see: http://blog.macsales.com/12247-upgrade-your-06-08-mac-pros-internal-bays-to-sata-3-0

        Like

      3. Very cool Steve, thanks for that link. DeeGee and I were referring to 5,1s that we’ve recently upgraded to but that’s a great way of adding SATA III capability to the 1,1.

        Like

  23. I’ve been doing some research. When I was looking for SSDs I had about a billion tabs open and it’s only just now that I see I must have been confused because of that what with trying to get the best price etc etc.
    So, my BlackMagic disk speed test with the SSD in a normal SATA caddy slot gave me 219.5 & 176.1MB/s for read & write so I was expecting an improvement on that.
    Anyhow a quick trip to the Toshiba website tells me that my speeds should max out at 220 & 180MB/s so I’m actually doing really well considering I don’t trim it or anything.

    I’m now looking for a Samsung. Trouble is it’s very difficult to compare SSDs. For some reason, (don’t know why I don’t like Crucial).

    Like

      1. In the 5,1 I have a Crucial SSD installed on a Apricorn Velocity Solo II, Blackmagic is showing write speeds of around 230 MB/s and read of around 460 MB/s. I also have mechanical HDD’s set up as RAID in the standard bays which are averaging around 310 MB/s write and 334MB/s read.

        Black Magic Disk Speed Test

        Like

  24. Looks pretty good. Which drive is that exactly? I’m trying to see what differs in each of their ranges, (MX100, MX200, BX100, M)?

    Like

  25. I have a mac pro 4,1 early 2009 4-core single CPU just wondering what options i had for upgrading to 16GB currently i have (4) 1GB sticks. Would this memory work 16GB Crucial Micron (2x8GB) DDR3 PC3-8500 ECC 240-pin CT102472BB10677Q? I also read that pairs of 3 is the best performance but not sure how to keep my expenses to $100 for atleast 12 or 16GB. Any help is appreciated. THanks

    Like

  26. I have updated my Mac Pro 1,1 HD from 10.6.8 to 10.8, with the HD removed from the Mac and attached via USB to a MacBookAir running 10.8. I managed to replace the boot.efi with Tiamo’s version in coreservices manually, but there is no trace of any usr/standalone/i386 either on the Air or on the Pro HD. I have tried the Terminal approach and looked for the folder manually. Any ideas? (I would upgrade to 10.9 but the installer refuses to run, saying that it cannot be run from that disk drive.)
    The 10.8 install as it is right now just loops when used for booting the Pro.

    Like

      1. I suppose so. I’ve always made the changes manually tho, you can see where things go wrong..

        Like

  27. Hello everyone. I tried to install mavericks on my macbook air 1,1. I made the USB but it doesn’t work for me. So, I decided to repeat the process with an internal partition. Finished the process and everything is ok and I turn off my computer. So, I hit the ‘alt’ key and I select the SFOTT partition but It runs with my normal OS (Lion). Any suggestion? Pls help me.

    Like

  28. I stumbled on a different thread and wondered if anyone here was aware of it. It is the Samsung XP941 500GB. It is expensive but apparently it works with the Mac Pro 1,1.

    https://discussions.apple.com/thread/6779268

    I may have kept the 1,1 if i had know that. I sold it got a mac pro 4,1 now but still need to upgrade to a SSD. Any recommendations? Budget $200. I was thinking of getting the Velocity PCIe card along with an 840 or 850 EVO but it looks like i need more education because there are many different variations and prices (V-NAND/3D NAND) pro or not pro etc.

    Like

    1. Strangely enough, that is as near as dammit what happened to me, (except I bought a 5,1). The Hatter is well known and well respected as one who knows the cheese grater Mac Pro.
      I have the Velocity x2 Duo card fitted with a 1GB Samsung 840 and a 512GB Toshiba.
      The Samsung has OSX10.10.2 on it and the Tosh has Win8.1.
      I don’t see any need to spend more.

      Like

    2. I have been trying to understand that thread. The XP941 seems great. And if you can use the Sintech adapter on a MacPro1,1, and a cheap USB3 housing and make the XP941 into an external drive foe modern MBPs, I would buy a load of them.

      Can someone clarify the limit of the PCIe1.0 on the MacPro1,1 for me – and how the Sintech/XP941 combination works?

      Like

  29. didn’t go quite that way, but close enough. I may have been impatient waiting for access to the new drive.
    In any case, after the install was complete, I rebooted into TDM again and did the Terminal changes.
    I’m on 10.9.5, but starting in verbose. How do I defeat that?
    Need to upgrade my graphics card.

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s