Epson TF-20 Boot Disk Creation

As I mentioned in an earlier entry, the Epson TF-20 5.25 inch floppy drive requires its OS to be loaded from disk before the unit will communicate and work with the PX-8.

My over riding intention since acquiring the TF-20 has been to back up the single boot disk that came with the system given that it’s over 20 years old and should the disk have failed the drive would have been rendered useless.

My initial attempts failed, although I have a copy of Copydisk and it was apparently successfully formatting and creating disks with the system tracks, when I tried to boot the drive with those disks, no luck.

I spoke to F J Kraan who advised that the proper disk type was Double Density (DD) as opposed to the High Density (HD) that I was using.  I tracked down some DD disks and repeated the process and it works.  I have of course therefore made several back up boot disks and feel somewhat relieved.

Incidentally the HD disks give the impression of working for general file usage, but success is intermittent, with occasional bad sector errors.  Meanwhile the working PF-10 has decided to well, stop working, hopefully this last burst of activity wasn’t its last hurrah.

I’m waiting on some C size batteries to try in the drive to see if it’s a battery issue or not.  Meanwhile I took one of the PF-10’s apart and took some crumb trail pictures with my phone.

(Update:- I’ve installed the four new C size batteries in the PF-10, but still no joy, harumph!)

3 thoughts on “Epson TF-20 Boot Disk Creation

  1. That battery in the last picture might need swapping out? At 100mah I would guess it’s something to do with backup? Mind, I suppose floppy drives don’t use a great deal of juice. ‘K4 PF1’ is the EPROM containing the microcontroller code – the sticker protects the erase window from being exposed to UV. My guess would be that the socketed chip below the EPROM is the processor. Hope you got it back together ok!

    Like

  2. Indeed, the battery on the board kicks in when the main battery runs out and the battery light on the unit starts to flash warning you to stop activity and recharge. What I don’t know is whether you need a functioning, healthy backup battery regardless of the charge in the main battery?

    Swapping out the backup battery is beyond my abilities as it’s soldered in. I think I’ve reassembled the unit successfully, do you have any idea what the odd looking six prong riser plug thingamyjig in the third picture labelled CN3 is for?

    Like

  3. well, it’s a connector of some description, CN being a standard was of labelling connectors 😉 However, what it is for I don’t know – not sure why it’s so long, seems a bit strange If I had to guess I would say it’s either a test point used during manufacturing, or, it’s a connector for a daughter card that sat on top and plugged into it.

    Regarding batteries – sometimes kit won’t function with a dead battery. If it’s a backup battery I would say it’s highly likely the design relies on it having charge. Not sure what the implications of it not having charge are mind. Well, not in a disk drive anyway.

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s